Arbitrary File Read

Affecting jekyll gem, versions >=3.6.0, <3.6.2 || >=3.7.0, <3.7.4 || >=3.8.0, <3.8.4

high severity

Overview

Jekyll is a simple, blog aware, static site generator.

Affected versions of this package are vulnerable to Arbitrary File Read. A malicious user could access arbitrary files by specifying a symlink in the include key via the _config.yml file.

Remediation

Upgrade jekyll to version 3.6.3, 3.7.4, 3.8.4 or higher.

References

Do your applications use this vulnerable package?

Credit
Unknown
CVE
CVE-2018-17567
CWE
CWE-94
Snyk ID
SNYK-RUBY-JEKYLL-72417
Disclosed
19 Sep, 2018
Published
03 Oct, 2018