DLL Loading Issue

Affecting ffi gem, versions <1.9.24

Do your applications use this vulnerable package? Test your applications

Overview

ffi is a ruby extension for programmatically loading dynamic libraries, binding functions within them, and calling those functions from Ruby code.

Affected versions of this package are vulnerable to DLL Loading Issue on Windows OS, when a Symbol is used as DLL name instead of a String.

Remediation

Upgrade ffi to version 1.9.24 or higher.

References

CVSS Score

7.8
high severity
  • Attack Vector
    Local
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Credit
Unknown
CVE
CVE-2018-1000201
CWE
CWE-427
Snyk ID
SNYK-RUBY-FFI-22037
Disclosed
22 Jun, 2018
Published
28 Jun, 2018