SQL Injection

Affecting sqlalchemy package, versions [,1.2.18)

Overview

sqlalchemy is a python SQL Toolkit and Object Relational Mapper.

Affected versions of this package are vulnerable to SQL Injection when the group_by and order_by parameter can be controlled.

Remediation

Upgrade sqlalchemy to version 1.2.18 or higher.

References

Do your applications use this vulnerable package?

CVSS Score

7.8
high severity
  • Attack Vector
    Local
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Credit
Unknown
CVE
CVE-2019-7164 CVE-2019-7548
CWE
CWE-89
Snyk ID
SNYK-PYTHON-SQLALCHEMY-173678
Disclosed
01 Feb, 2019
Published
11 Feb, 2019