Malicious Package

Affecting djanga package, versions [0,]

Do your applications use this vulnerable package? Test your applications

Overview

12 Python libraries were identified as malicious packages. djanga, easyinstall and libpeshka packages injected code into the .bashrc file when installed on a linux system.

On October 13th, 2018 all of these packages have been removed from Pypi.

Remediation

Avoid usage of this package altogether.

References

CVSS Score

9.8
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Credit
Bertus
CWE
CWE-506
Snyk ID
SNYK-PYTHON-DJANGA-72533
Disclosed
13 Oct, 2018
Published
28 Oct, 2018