Information Exposure

Affecting ansible package, versions [,2.5.14) || [2.6.0, 2.6.11) || [2.7.0, 2.7.5)

Do your applications use this vulnerable package? Test your applications

Overview

ansible is a simple IT automation system.

Affected versions of this package are vulnerable to Information Exposure. When a retry task run with -vvv fails, it would log the raw return code, stdout and stderr from ssh which could have contained sensitive data.

Remediation

Upgrade ansible to version 2.5.14, 2.6.11, 2.7.5 or higher.

References

CVSS Score

3.1
low severity
  • Attack Vector
    Network
  • Attack Complexity
    High
  • Privileges Required
    Low
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    None
  • Availability
    None
CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N
Credit
Unknown
CVE
CVE-2018-16876
CWE
CWE-200
Snyk ID
SNYK-PYTHON-ANSIBLE-72696
Disclosed
07 Dec, 2018
Published
18 Dec, 2018