Cross-site Request Forgery (CSRF)

Affecting moodle/moodle package, versions <3.1.15 || >=3.2.0, <3.3.9 || >=3.4.0, <3.4.6 || >=3.5.0, <3.5.3

medium severity

Overview

moodle/moodle is an open source learning platform.

Affected versions of this package are vulnerable to Cross-site Request Forgery. The login form was not protected by a token to prevent login CSRF.

Remediation

Upgrade moodle/moodle to versions 3.6, 3.5.3, 3.4.6, 3.3.9, 3.1.15 or higher.

References

Do your applications use this vulnerable package?

Credit
Unknown
CVE
CVE-2018-16854
CWE
CWE-352
Snyk ID
SNYK-PHP-MOODLEMOODLE-72639
Disclosed
26 Nov, 2018
Published
28 Nov, 2018