Incorrect Access Control

Affecting api-platform/core package, versions <2.3.6

Overview

api-platform/core builds a fully-featured hypermedia or GraphQL API in minutes.

Affected versions of this package are vulnerable to Incorrect Access Control via the GraphQL delete mutations. A malicious authorized user is able to delete some different resources.

Remediation

Upgrade api-platform/core to version 2.3.6 or higher.

References

Do your applications use this vulnerable package?

CVSS Score

5.5
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    High
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    High
  • Availability
    Low
CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:L
Credit
Unknown
CVE
CVE-2019-1000011
CWE
CWE-284
Snyk ID
SNYK-PHP-APIPLATFORMCORE-73646
Disclosed
04 Feb, 2019
Published
05 Feb, 2019