Arbitrary Command Injection

Affecting ascii-art package, versions <1.4.4

Overview

ascii-art is a library for ansi codes, figlet fonts, ascii art and other ASCII graphics.

Affected versions of this package are vulnerable to Arbitrary Command Injection via malicious crafted command line argument.

Remediation

Upgrade ascii-art to version 1.4.4 or higher.

References

Do your applications use this vulnerable package?

CVSS Score

8.6
high severity
  • Attack Vector
    Local
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Changed
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
Credit
Douglas Hall
CWE
CWE-94
Snyk ID
SNYK-JS-ASCIIART-72306
Disclosed
09 Sep, 2018
Published
09 Sep, 2018