Replay attack

Affecting org.keycloak:keycloak-services artifact, versions [,4.6.0)

medium severity

Overview

org.keycloak:keycloak-services is an Open Source Identity and Access Management For Modern Applications and Services.

Affected versions of this package are vulnerable to Replay attack due to the SAML broker consumer endpoint which ignored expiration conditions on SAML assertions.

Remediation

Upgrade org.keycloak:keycloak-services to version 4.6.0 or higher.

References

Do your applications use this vulnerable package?

Credit
Unknown
CVE
CVE-2018-14637
CWE
CWE-294
Snyk ID
SNYK-JAVA-ORGKEYCLOAK-72652
Disclosed
30 Nov, 2018
Published
03 Dec, 2018