User Impersonation

Affecting org.jenkins-ci.plugins:github-oauth artifact, versions [0.29, 0.31)

Do your applications use this vulnerable package? Test your applications

Overview

org.jenkins-ci.plugins:github-oauth is a Jenkins authentication plugin using GitHub OAuth as the source.

Affected versions of this package are vulnerable to User Impersonation. It allows unauthorized attackers to impersonate another user if they can control the pre-authentication session.

Remediation

Upgrade org.jenkins-ci.plugins:github-oauth to version 0.31 or higher.

References

CVSS Score

6.5
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    None
  • Availability
    None
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N
Credit
Wadeck Follonier
CVE
CVE-2019-1003019
CWE
CWE-520
Snyk ID
SNYK-JAVA-ORGJENKINSCIPLUGINS-173673
Disclosed
28 Jan, 2019
Published
06 Feb, 2019