Arbitrary Code Execution

Affecting org.apache.syncope:syncope-core artifact, versions [1.0.0,1.0.9), [1.1.0,1.1.7)

Do your applications use this vulnerable package? Test your applications

Overview

org.apache.syncope:syncope-core Apache Syncope 1.0.0 before 1.0.9 and 1.1.0 before 1.1.7 allows remote administrators to execute arbitrary Java code via vectors related to Apache Commons JEXL expressions, "derived schema definition," "user / role templates," and "account links of resource mappings."

References

CVSS Score

6.3
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    Low
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    Low
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
Credit
Unknown
CVE
CVE-2014-0111
CWE
CWE-94
Snyk ID
SNYK-JAVA-ORGAPACHESYNCOPE-30805
Disclosed
06 Jun, 2014
Published
06 Jun, 2014