Information Exposure

Affecting org.apache.mina:mina-core artifact, versions [,2.0.21) || [2.1.0,2.1.1)

Do your applications use this vulnerable package? Test your applications

Overview

org.apache.mina:mina-core is a network application framework which helps users develop high performance and high scalability network applications easily.

Affected versions of this package are vulnerable to Information Exposure. Handling of the close_notify SSL/TLS message does not lead to a connection closure, leading the server to retain the socket opened and to have the client potentially receive clear-text messages which were supposed to be encrypted.

Remediation

Upgrade org.apache.mina:mina-core to version 2.0.21, 2.1.1 or higher.

References

CVSS Score

6.8
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    High
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    None
CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N
Credit
Marian Rehak
CVE
CVE-2019-0231
CWE
CWE-319
Snyk ID
SNYK-JAVA-ORGAPACHEMINA-174326
Disclosed
14 Apr, 2019
Published
17 Apr, 2019