Information Exposure

Affecting org.apache.hadoop:hadoop-hdfs-client artifact, versions [3.0.0-alpha1,3.0.1) || [2.9.0,2.9.1) || [2.8.0,2.8.4) || [2.5.0,2.7.6)

Overview

org.apache.hadoop:hadoop-hdfs-client is the Apache Hadoop HDFS Client.

Affected versions of this package are vulnerable to Information Exposure. The package exposes extended attribute key/value pairs during listXAttrs, verifying only path-level search access to the directory rather than path-level read permission to the referent.

Remediation

Upgrade org.apache.hadoop:hadoop-hdfs-client to version 3.0.1, 2.9.1, 2.8.4, 2.7.6 or higher.

References

Do your applications use this vulnerable package?

CVSS Score

5.6
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    High
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    Low
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L
Credit
Rushabh Shah
CVE
CVE-2018-1296
CWE
CWE-200
Snyk ID
SNYK-JAVA-ORGAPACHEHADOOP-173666
Disclosed
08 Feb, 2019
Published
08 Feb, 2019