Authentication Bypass

Affecting github.com/grafana/grafana/pkg/services package, versions <4.6.4 || >=5.0.0 <5.2.3

high severity

Overview

github.com/grafana/grafana/pkg/services is a tool for monitoring and metric analytics & dashboards for Graphite, InfluxDB & Prometheus & More.

Affected versions of the package are vulnerable to Authentication Bypass. An attacker could generate a valid cookie knowing only a username of an LDAP or OAuth user.

Remediation

Upgrade github.com/grafana/grafana/pkg/services to version 4.6.4, 5.2.3 or higher.

References

Do your applications use this vulnerable package?

Credit
Unknown
CVE
CVE-2018-15727
CWE
CWE-592
Snyk ID
SNYK-GOLANG-GITHUBCOMGRAFANAGRAFANAPKGSERVICES-50088
Disclosed
19 Aug, 2018
Published
02 Sep, 2018