Remote Code Execution

Affecting github.com/go-gitea/gitea package, versions <1.5.2

high severity

Overview

go-gitea/gitea is a self-hosted git service.

Affected versions of this package are vulnerable to Remote Code Execution due to not properly validating session IDs. This is related to session ID handling in the go-macaron/session code for Macaron.

Remediation

Upgrade `go-gitea/gitea' to version 1.5.2 or higher.

References

Do your applications use this vulnerable package?

Credit
Unknown
CVE
CVE-2018-18926
CWE
CWE-94
Snyk ID
SNYK-GOLANG-GITHUBCOMGOGITEAGITEA-72635
Disclosed
04 Nov, 2018
Published
28 Nov, 2018