passenger vulnerabilities

A modern web server and application server for Ruby, Python and Node.js, optimized for performance, low memory usage and ease of use.

Latest version: 6.0.2

Licenses detected

Continuously find & fix vulnerabilities like these in your dependencies. Test and protect your applications

Direct Vulnerabilities

Known vulnerabilities in the passenger package. This does not include vulnerabilities belonging to this package’s dependencies.

Vulnerability Vulnerable versions Snyk patch Published
  • M
Privilege Escalation
<5.3.2 Not available 30 Apr, 2019
  • H
Privilege Escalation
<5.3.2 Not available 20 Jun, 2018
  • H
Improper Access Control
<5.3.2 Not available 20 Jun, 2018
  • H
Insecure Permissions
<5.3.2 Not available 20 Jun, 2018
  • H
Arbitrary File Write
<5.3.2 Not available 20 Jun, 2018
  • M
Arbitrary File Read
<5.1.11 Not available 28 Nov, 2017
  • H
Privilege Escalation
<5.1.0 Not available 07 Jun, 2017
  • L
Symlink Attack
< 5.0.22, >= 4.1,< 4.0.60 Not available 22 Nov, 2015
  • M
Symlink File Overwrite
< 4.0.38 Not available 28 Jan, 2014
  • M
Symlink File Overwrite
< 4.0.37 Not available 27 Jan, 2014
  • M
Symlink Attack
< 4.0.8 Not available 09 Jun, 2013
  • M
Symlink Attack
< 4.0.5, >= 3.1,< 3.0.21 Not available 28 May, 2013
  • L
Symlink File Overwrite
< 4.0.0.rc1, >= 4.0.0.a Not available 31 Jan, 2012