ansible vulnerabilities

Radically simple IT automation

Latest version: 2.8.0

Licenses detected

Continuously find & fix vulnerabilities like these in your dependencies. Test and protect your applications

Direct Vulnerabilities

Known vulnerabilities in the ansible package. This does not include vulnerabilities belonging to this package’s dependencies.

Vulnerability Vulnerable versions Snyk patch Published
  • M
Directory Traversal
[2.5.0, 2.5.15),[2.6.0, 2.6.14),[2.7.0, 2.7.8) Not available 27 Mar, 2019
  • L
Information Exposure
[,2.5.14),[2.6.0, 2.6.11),[2.7.0, 2.7.5) Not available 18 Dec, 2018
  • M
Information Exposure
[,2.5.12),[26.0, 2.6.9),[2.7.2, 2.7.3) Not available 03 Dec, 2018
  • H
Information Exposure
[,2.7.1) Not available 29 Oct, 2018
  • H
Arbitrary Code Injection
[,2.3.1.0) Not available 23 Jul, 2018
  • H
Information Exposure
[,2.5.5) Not available 19 Jun, 2018
  • H
Arbitrary Code Execution
[1.9,1.9.7) Not available 11 Apr, 2017
  • H
Arbitrary Command Execution
[2.1.3.0] Not available 09 Jan, 2017
  • H
Arbitrary Command Execution
[,2.1.3) Not available 01 Nov, 2016
  • H
Improper Key Validation
[2,2.1.3) Not available 01 Nov, 2016
  • H
Arbitrary Code Execution
[1.9.5,1.9.6), [2,2.0.2.0) Not available 08 Apr, 2016
  • H
Arbitrary Code Execution
[,1.6.4) Not available 03 Mar, 2016
  • L
Symlink Attack
[,1.2.3) Not available 23 Feb, 2016
  • M
Arbitrary File Overwrite
[1.2,1.2.3) Not available 23 Feb, 2016
  • H
Symlink Attack
[,1.9.2) Not available 17 Aug, 2015
  • M
Man-in-the-Middle (MitM)
[,1.9.2) Not available 15 Jul, 2015
  • H
Arbitrary Code Execution
[,1.5.4) Not available 01 Apr, 2014