Cross-site Request Forgery (CSRF)

Affecting auth0-js package, versions <9.0.0

Overview

auth0-js is a Client Side Javascript toolkit for Auth0 API.

Affected versions of this package are vulnerable to Cross-Site Request Forgery (CSRF) attacks if the Legacy Lock API flag is enabled.

Once the user credentials are verified, an HTML form is rendered into the user’s browser. A JSON Web Token (JWT) is POSTed to the /login/callback endpoint, and it maintains state regarding the identity of the user. Due to the lack of session binding, this form post is susceptible to CSRF. An attacker with valid user credentials at an Auth0 tenant can use them to gain such a form, and then employ techniques such as social engineering or clickjacking to have a victim’s browser execute it.

Remediation

Upgrade auth0-js to version 9.0.0 or higher.

References

Do your applications use this vulnerable package?

CVSS Score

6.5
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    None
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
Credit
Unknown
CVE
CVE-2018-6874
CWE
CWE-352
Snyk ID
npm:auth0-js:20180409
Disclosed
09 Apr, 2018
Published
09 Apr, 2018