apollo-upload-server vulnerabilities

Middleware and an Upload scalar to add support for GraphQL multipart requests (file uploads via queries and mutations) to various Node.js GraphQL servers.

Latest version: 7.1.0

Licenses detected

  • license: MIT >=0
Continuously find & fix vulnerabilities like these in your dependencies. Test and protect your applications

Direct Vulnerabilities

Known vulnerabilities in the apollo-upload-server package. This does not include vulnerabilities belonging to this package’s dependencies.

Vulnerability Vulnerable versions Snyk patch Published
  • H
Denial of Service (DoS)
<7.0.0 Not available 30 Oct, 2018
  • H
Denial of Service (DoS)
<7.0.0 Not available 29 Oct, 2018
Versions
Version Published Licenses Direct Vulnerabilities
7.1.0 04 Sep, 2018 MIT
  • 0 H
  • 0 M
  • 0 L
7.0.0 17 Aug, 2018 MIT
  • 0 H
  • 0 M
  • 0 L
6.0.0-alpha.1 21 Jul, 2018 MIT
  • 2 H
  • 0 M
  • 0 L
5.0.0 09 Mar, 2018 MIT
  • 2 H
  • 0 M
  • 0 L
4.0.2 29 Jan, 2018 MIT
  • 2 H
  • 0 M
  • 0 L
4.0.1 29 Jan, 2018 MIT
  • 2 H
  • 0 M
  • 0 L
4.0.0 29 Jan, 2018 MIT
  • 2 H
  • 0 M
  • 0 L
4.0.0-alpha.3 15 Jan, 2018 MIT
  • 2 H
  • 0 M
  • 0 L
4.0.0-alpha.2 03 Jan, 2018 MIT
  • 2 H
  • 0 M
  • 0 L
4.0.0-alpha.1 19 Nov, 2017 MIT
  • 2 H
  • 0 M
  • 0 L
3.0.0 18 Nov, 2017 MIT
  • 2 H
  • 0 M
  • 0 L
2.0.4 13 Jul, 2017 MIT
  • 2 H
  • 0 M
  • 0 L
2.0.3 25 Jun, 2017 MIT
  • 2 H
  • 0 M
  • 0 L
2.0.2 20 Jun, 2017 MIT
  • 2 H
  • 0 M
  • 0 L
2.0.1 05 Apr, 2017 MIT
  • 2 H
  • 0 M
  • 0 L
2.0.0 26 Mar, 2017 MIT
  • 2 H
  • 0 M
  • 0 L
1.1.1 19 Mar, 2017 MIT
  • 2 H
  • 0 M
  • 0 L
1.1.0 01 Mar, 2017 MIT
  • 2 H
  • 0 M
  • 0 L
1.0.1 24 Feb, 2017 MIT
  • 2 H
  • 0 M
  • 0 L
1.0.2 24 Feb, 2017 MIT
  • 2 H
  • 0 M
  • 0 L
1.0.0 24 Feb, 2017 MIT
  • 2 H
  • 0 M
  • 0 L