org.springframework.security:spring-security-core vulnerabilities

spring-security-core

Latest version: 5.1.5.RELEASE

Licenses detected

Continuously find & fix vulnerabilities like these in your dependencies. Test and protect your applications

Direct Vulnerabilities

Known vulnerabilities in the org.springframework.security:spring-security-core package. This does not include vulnerabilities belonging to this package’s dependencies.

Vulnerability Vulnerable versions Snyk patch Published
  • L
Insecure Randomness
[4.2.0, 4.2.12),[5.0.0, 5.0.12),[5.1.0, 5.1.5) Not available 05 Apr, 2019
  • M
Access Restriction Bypass
[4.1.0, 4.1.5),[4.2.0, 4.2.4),[5.0, 5.0.3) Not available 18 Mar, 2018
  • H
Deserialization of Untrusted Data
[,4.2.3),[5.0.0.M1,5.0.0.M2) Not available 20 Sep, 2017
  • H
Security Bypass
[3.2.0.RELEASE,3.2.10.RELEASE),[4.0.0.RELEASE,4.1.4.RELEASE),[4.2.0.RELEASE,4.2.1.RELEASE) Not available 28 Dec, 2016
  • H
Authentication Bypass
[3.2,3.2.2),[3.1,3.1.6) Not available 25 Dec, 2016
  • M
Information Exposure
[,2.0.8),[3,3.0.8),[3.1,3.1.3) Not available 25 Dec, 2016
  • M
Access Restriction Bypass
[2.0.0,2.0.6),[3,3.0.4) Not available 10 Jun, 2015
  • M
Improper Authentication
[,2.0.7),[3,3.0.6) Not available 08 Sep, 2014
  • M
Arbitrary Code Execution
[,2.0.7),[3,3.0.6) Not available 08 Sep, 2014
  • M
Access Restriction Bypass
[2,2.0.7),[3,3.0.6) Not available 08 Sep, 2014