zsh vulnerabilities

Continuously find & fix vulnerabilities like these in your dependencies. Test and protect your applications

Direct Vulnerabilities

Known vulnerabilities in the zsh package. This does not include vulnerabilities belonging to this package’s dependencies.

Vulnerability Vulnerable versions Snyk patch Published
  • M
RHSA-2018:3073
centos:7: <0:5.0.2-31.el7 Not available 29 Jan, 2019
  • M
ELSA-2018-3073
oracle:7: <0:5.0.2-31.el7 Not available 29 Jan, 2019
  • L
CVE-2018-0502
debian:10: <5.6-1,debian:8: *,debian:9: *,debian:unstable: <5.6-1,ubuntu:14.04: <5.0.2-3ubuntu6.3,ubuntu:16.04: <5.1.1-1ubuntu2.3,ubuntu:18.04: <5.4.2-3ubuntu3.1 Not available 25 Sep, 2018
  • L
CVE-2018-13259
debian:10: <5.6-1,debian:8: *,debian:9: *,debian:unstable: <5.6-1,ubuntu:14.04: <5.0.2-3ubuntu6.3,ubuntu:16.04: <5.1.1-1ubuntu2.3,ubuntu:18.04: <5.4.2-3ubuntu3.1 Not available 25 Sep, 2018
  • M
ELSA-2018-1932
oracle:6: <0:4.3.11-8.el6 Not available 16 Aug, 2018
  • M
RHSA-2018:1932
centos:6: <0:4.3.11-8.el6 Not available 27 Jun, 2018
  • L
Arbitrary Code Execution
debian:10: <5.5-1,debian:8: *,debian:9: *,debian:unstable: <5.5-1,ubuntu:14.04: <5.0.2-3ubuntu6.3,ubuntu:16.04: <5.1.1-1ubuntu2.3,ubuntu:18.04: <5.4.2-3ubuntu3.1 Not available 11 Apr, 2018
  • L
Privilege Escalation
alpine:3.4: <5.2-r2,alpine:3.5: <5.2-r4,alpine:3.6: <5.3.1-r1,alpine:3.7: <5.4.2-r1,alpine:3.8: <5.4.2-r1,alpine:3.9: <5.4.2-r1,debian:10: <5.4.2-4,debian:8: *,debian:9: *,debian:unstable: <5.4.2-4,ubuntu:14.04: <5.0.2-3ubuntu6.2,ubuntu:16.04: <5.1.1-1ubuntu2.2,ubuntu:17.10: <5.2-5ubuntu1.2 Not available 28 Mar, 2018
  • L
Denial of Service (DoS)
alpine:3.4: <5.2-r2,alpine:3.5: <5.2-r4,alpine:3.6: <5.3.1-r1,alpine:3.7: <5.4.2-r1,alpine:3.8: <5.4.2-r1,alpine:3.9: <5.4.2-r1,debian:10: <5.4.2-4,debian:8: *,debian:9: *,debian:unstable: <5.4.2-4,ubuntu:14.04: <5.0.2-3ubuntu6.2,ubuntu:16.04: <5.1.1-1ubuntu2.2,ubuntu:17.10: <5.2-5ubuntu1.2 Not available 09 Mar, 2018
  • M
Improper Restriction of Operations within the Bounds of a Memory Buffer
debian:10: <5.0.7-3,debian:8: <5.0.7-3,debian:9: <5.0.7-3,debian:unstable: <5.0.7-3,ubuntu:14.04: <5.0.2-3ubuntu6.1,ubuntu:17.10: <5.2-5ubuntu1.1 Not available 27 Feb, 2018
  • H
Improper Restriction of Operations within the Bounds of a Memory Buffer
debian:10: <5.0.6-1,debian:8: <5.0.6-1,debian:9: <5.0.6-1,debian:unstable: <5.0.6-1,ubuntu:14.04: <5.0.2-3ubuntu6.1,ubuntu:17.10: <5.2-5ubuntu1.1 Not available 27 Feb, 2018
  • H
Improper Restriction of Operations within the Bounds of a Memory Buffer
debian:10: <5.4.1-1,debian:8: *,debian:9: *,debian:unstable: <5.4.1-1,ubuntu:16.04: <5.1.1-1ubuntu2.1,ubuntu:17.10: <5.2-5ubuntu1.1 Not available 27 Feb, 2018
  • H
Numeric Errors
debian:10: <5.3-1,debian:8: *,debian:9: <5.3-1,debian:unstable: <5.3-1,ubuntu:14.04: <5.0.2-3ubuntu6.1,ubuntu:16.04: <5.1.1-1ubuntu2.1,ubuntu:17.10: <5.2-5ubuntu1.1 Not available 27 Feb, 2018
  • M
NULL Pointer Dereference
debian:10: <5.5-1,debian:8: *,debian:9: *,debian:unstable: <5.5-1,ubuntu:17.10: <5.2-5ubuntu1.1 Not available 27 Feb, 2018
  • L
NULL Pointer Dereference
debian:10: <5.4.1-1,debian:8: *,debian:9: *,debian:unstable: <5.4.1-1,ubuntu:14.04: <5.0.2-3ubuntu6.1,ubuntu:16.04: <5.1.1-1ubuntu2.1,ubuntu:17.10: <5.2-5ubuntu1.1 Not available 27 Feb, 2018
  • M
Improper Input Validation
debian:10: <5.5-1,debian:8: *,debian:9: *,debian:unstable: <5.5-1,ubuntu:14.04: <5.0.2-3ubuntu6.1,ubuntu:16.04: <5.1.1-1ubuntu2.1,ubuntu:17.10: <5.2-5ubuntu1.1 Not available 27 Feb, 2018
  • M
Privilege Escalation
debian:10: <5.0.7-3,debian:8: <5.0.7-3,debian:9: <5.0.7-3,debian:unstable: <5.0.7-3,ubuntu:14.04: <5.0.2-3ubuntu6.1,ubuntu:17.10: <5.2-5ubuntu1.1 Not available 27 Feb, 2018
  • L
Arbitrary File Overwrite
debian:10: <4.3.4-dev-3-2,debian:8: <4.3.4-dev-3-2,debian:9: <4.3.4-dev-3-2,debian:unstable: <4.3.4-dev-3-2 Not available 04 Dec, 2007