sox vulnerabilities

Continuously find & fix vulnerabilities like these in your dependencies. Test and protect your applications

Direct Vulnerabilities

Known vulnerabilities in the sox package. This does not include vulnerabilities belonging to this package’s dependencies.

Vulnerability Vulnerable versions Snyk patch Published
  • L
CVE-2019-8357
debian:10: *,debian:8: *,debian:9: *,debian:unstable: * Not available 16 Feb, 2019
  • L
CVE-2019-8356
debian:10: *,debian:8: *,debian:9: *,debian:unstable: * Not available 16 Feb, 2019
  • L
CVE-2019-8354
debian:10: *,debian:8: *,debian:9: *,debian:unstable: * Not available 16 Feb, 2019
  • L
CVE-2019-8355
debian:10: *,debian:8: *,debian:9: *,debian:unstable: * Not available 16 Feb, 2019
  • M
SoX: Multiple vulnerabilities
alpine:3.4: <14.4.2-r1,alpine:3.5: <14.4.2-r1,alpine:3.6: <14.4.2-r1,alpine:3.7: <14.4.2-r1,alpine:3.8: <14.4.2-r1 Not available 17 Oct, 2018
  • H
SoX: Multiple buffer overflows
alpine:3.4: <=12.17.4-r1,alpine:3.5: <=12.17.4-r1,alpine:3.6: <=12.17.4-r1,alpine:3.7: <=12.17.4-r1,alpine:3.8: <=12.17.4-r1 Not available 17 Oct, 2018
  • H
SoX: User-assisted execution of arbitrary code
alpine:3.4: <14.4.2,alpine:3.5: <14.4.2,alpine:3.6: <14.4.2,alpine:3.7: <14.4.2,alpine:3.8: <14.4.2 Not available 17 Oct, 2018
  • M
NULL Pointer Dereference
debian:10: <14.4.2-2,debian:8: <14.4.1-5+deb8u2,debian:9: *,debian:unstable: <14.4.2-2,ubuntu:14.04: <14.4.1-3ubuntu1.1,ubuntu:16.04: <14.4.1-5ubuntu0.1 Not available 15 Feb, 2018
  • M
Use After Free
debian:10: <14.4.2-2,debian:8: <14.4.1-5+deb8u2,debian:9: *,debian:unstable: <14.4.2-2,ubuntu:14.04: <14.4.1-3ubuntu1.1,ubuntu:16.04: <14.4.1-5ubuntu0.1 Not available 19 Oct, 2017
  • M
Denial of Service (DoS)
debian:10: <14.4.2-2,debian:8: <14.4.1-5+deb8u2,debian:9: *,debian:unstable: <14.4.2-2,ubuntu:14.04: <14.4.1-3ubuntu1.1,ubuntu:16.04: <14.4.1-5ubuntu0.1 Not available 16 Oct, 2017
  • M
Denial of Service (DoS)
debian:10: <14.4.2-2,debian:8: <14.4.1-5+deb8u3,debian:9: *,debian:unstable: <14.4.2-2,ubuntu:14.04: <14.4.1-3ubuntu1.1,ubuntu:16.04: <14.4.1-5ubuntu0.1 Not available 16 Oct, 2017
  • M
Denial of Service (DoS)
debian:10: <14.4.2-2,debian:8: <14.4.1-5+deb8u2,debian:9: *,debian:unstable: <14.4.2-2,ubuntu:14.04: <14.4.1-3ubuntu1.1,ubuntu:16.04: <14.4.1-5ubuntu0.1 Not available 16 Oct, 2017
  • M
Denial of Service (DoS)
debian:10: <14.4.2-2,debian:8: <14.4.1-5+deb8u3,debian:9: *,debian:unstable: <14.4.2-2,ubuntu:14.04: <14.4.1-3ubuntu1.1,ubuntu:16.04: <14.4.1-5ubuntu0.1 Not available 31 Jul, 2017
  • M
Denial of Service (DoS)
debian:10: <14.4.2-2,debian:8: <14.4.1-5+deb8u3,debian:9: *,debian:unstable: <14.4.2-2,ubuntu:14.04: <14.4.1-3ubuntu1.1,ubuntu:16.04: <14.4.1-5ubuntu0.1 Not available 31 Jul, 2017
  • M
Denial of Service (DoS)
debian:10: <14.4.2-2,debian:8: <14.4.1-5+deb8u3,debian:9: *,debian:unstable: <14.4.2-2,ubuntu:14.04: <14.4.1-3ubuntu1.1,ubuntu:16.04: <14.4.1-5ubuntu0.1 Not available 31 Jul, 2017
  • M
Improper Restriction of Operations within the Bounds of a Memory Buffer
debian:10: <14.4.2-2,debian:8: <14.4.1-5+deb8u1,debian:9: <14.4.1-5+deb9u1,debian:unstable: <14.4.2-2,ubuntu:14.04: <14.4.1-3ubuntu1.1,ubuntu:16.04: <14.4.1-5ubuntu0.1 Not available 31 Dec, 2014
  • H
Buffer Overflow
debian:10: <12.17.4-9,debian:8: <12.17.4-9,debian:9: <12.17.4-9,debian:unstable: <12.17.4-9 Not available 06 Aug, 2004