nasm vulnerabilities

Continuously find & fix vulnerabilities like these in your dependencies. Test and protect your applications

Direct Vulnerabilities

Known vulnerabilities in the nasm package. This does not include vulnerabilities belonging to this package’s dependencies.

Vulnerability Vulnerable versions Snyk patch Published
  • H
CWE-416
debian:10: *,debian:8: *,debian:9: *,debian:unstable: *,ubuntu:14.04: *,ubuntu:16.04: *,ubuntu:18.04: *,ubuntu:18.10: * Not available 15 Feb, 2019
  • M
CWE-119
ubuntu:14.04: *,ubuntu:16.04: *,ubuntu:18.04: *,ubuntu:18.10: * Not available 29 Jan, 2019
  • L
CVE-2019-6291
debian:10: *,debian:8: *,debian:9: *,debian:unstable: *,ubuntu:14.04: *,ubuntu:16.04: *,ubuntu:18.04: *,ubuntu:18.10: * Not available 15 Jan, 2019
  • L
CVE-2019-6290
debian:10: *,debian:8: *,debian:9: *,debian:unstable: *,ubuntu:14.04: *,ubuntu:16.04: *,ubuntu:18.04: *,ubuntu:18.10: * Not available 15 Jan, 2019
  • L
CVE-2018-20535
debian:10: *,debian:8: *,debian:9: *,debian:unstable: *,ubuntu:14.04: *,ubuntu:16.04: *,ubuntu:18.04: *,ubuntu:18.10: * Not available 28 Dec, 2018
  • L
CVE-2018-20538
debian:10: *,debian:8: *,debian:9: *,debian:unstable: *,ubuntu:14.04: *,ubuntu:16.04: *,ubuntu:18.04: *,ubuntu:18.10: * Not available 28 Dec, 2018
  • L
CVE-2018-1000886
debian:10: *,debian:8: *,debian:9: *,debian:unstable: *,ubuntu:14.04: *,ubuntu:16.04: *,ubuntu:18.04: *,ubuntu:18.10: * Not available 20 Dec, 2018
  • L
CVE-2018-19216
debian:10: <2.13.02-0.1,debian:8: *,debian:9: *,debian:unstable: <2.13.02-0.1,ubuntu:14.04: *,ubuntu:16.04: *,ubuntu:18.04: *,ubuntu:18.10: * Not available 02 Dec, 2018
  • L
CVE-2018-19214
debian:10: <2.14-1,debian:8: *,debian:9: *,debian:unstable: <2.14-1,ubuntu:14.04: *,ubuntu:16.04: *,ubuntu:18.04: *,ubuntu:18.10: * Not available 02 Dec, 2018
  • L
CVE-2018-19215
debian:10: <2.14-1,debian:8: *,debian:9: *,debian:unstable: <2.14-1,ubuntu:14.04: *,ubuntu:16.04: *,ubuntu:18.04: *,ubuntu:18.10: * Not available 02 Dec, 2018
  • L
CVE-2018-19213
debian:10: *,debian:8: *,debian:9: *,debian:unstable: *,ubuntu:14.04: *,ubuntu:16.04: *,ubuntu:18.04: *,ubuntu:18.10: * Not available 02 Dec, 2018
  • L
CVE-2018-19209
debian:10: <2.14-1,debian:8: *,debian:9: *,debian:unstable: <2.14-1,ubuntu:14.04: *,ubuntu:16.04: *,ubuntu:18.04: *,ubuntu:18.10: * Not available 02 Dec, 2018
  • M
CVE-2018-19755
debian:10: *,debian:8: *,debian:9: *,debian:unstable: *,ubuntu:14.04: *,ubuntu:16.04: *,ubuntu:18.04: *,ubuntu:18.10: * Not available 30 Nov, 2018
  • H
NASM: Buffer overflow vulnerability
alpine:3.4: <=0.98.38,alpine:3.5: <=0.98.38,alpine:3.6: <=0.98.38,alpine:3.7: <=0.98.38,alpine:3.8: <=0.98.38 Not available 17 Oct, 2018
  • L
CVE-2018-16382
debian:10: <2.14-1,debian:8: *,debian:9: *,debian:unstable: <2.14-1,ubuntu:14.04: *,ubuntu:16.04: *,ubuntu:18.04: *,ubuntu:18.10: * Not available 25 Sep, 2018
  • L
CVE-2018-16999
debian:10: <2.14-1,debian:8: *,debian:9: *,debian:unstable: <2.14-1,ubuntu:14.04: *,ubuntu:16.04: *,ubuntu:18.04: *,ubuntu:18.10: * Not available 25 Sep, 2018
  • L
CVE-2018-1000667
debian:10: <2.14-1,debian:8: *,debian:9: *,debian:unstable: <2.14-1,ubuntu:14.04: *,ubuntu:16.04: *,ubuntu:18.04: *,ubuntu:18.10: * Not available 25 Sep, 2018
  • L
CVE-2018-16517
debian:10: <2.14-1,debian:8: *,debian:9: *,debian:unstable: <2.14-1,ubuntu:14.04: *,ubuntu:16.04: *,ubuntu:18.04: *,ubuntu:18.10: * Not available 25 Sep, 2018
  • L
Integer Overflow or Wraparound
debian:10: <2.14-1,debian:8: *,debian:9: *,debian:unstable: <2.14-1,ubuntu:14.04: *,ubuntu:16.04: *,ubuntu:18.04: *,ubuntu:18.10: * Not available 24 Apr, 2018
  • M
Denial of Service (DoS)
debian:10: <2.14-1,debian:8: *,debian:9: *,debian:unstable: <2.14-1,ubuntu:14.04: *,ubuntu:16.04: *,ubuntu:18.04: *,ubuntu:18.10: * Not available 21 Apr, 2018
  • M
Denial of Service (DoS)
debian:10: <2.14-1,debian:8: *,debian:9: *,debian:unstable: <2.14-1,ubuntu:14.04: *,ubuntu:16.04: *,ubuntu:18.04: *,ubuntu:18.10: * Not available 11 Apr, 2018
  • L
Improper Restriction of Operations within the Bounds of a Memory Buffer
debian:10: <2.14-1,debian:8: *,debian:9: *,debian:unstable: <2.14-1,ubuntu:14.04: *,ubuntu:16.04: *,ubuntu:18.04: *,ubuntu:18.10: * Not available 20 Mar, 2018
  • L
Improper Restriction of Operations within the Bounds of a Memory Buffer
debian:10: <2.13.02-0.1,debian:8: *,debian:9: *,debian:unstable: <2.13.02-0.1,ubuntu:14.04: <2.10.09-1ubuntu0.1,ubuntu:16.04: <2.11.08-1ubuntu0.1,ubuntu:17.10: <2.13.01-2ubuntu0.1 Not available 20 Mar, 2018
  • L
Improper Restriction of Operations within the Bounds of a Memory Buffer
debian:10: <2.14-1,debian:8: *,debian:9: *,debian:unstable: <2.14-1,ubuntu:14.04: *,ubuntu:16.04: *,ubuntu:18.04: *,ubuntu:18.10: * Not available 20 Mar, 2018
  • L
Denial of Service (DoS)
debian:10: <2.13.02-0.1,debian:8: *,debian:9: *,debian:unstable: <2.13.02-0.1,ubuntu:14.04: <2.10.09-1ubuntu0.1,ubuntu:16.04: <2.11.08-1ubuntu0.1,ubuntu:17.10: <2.13.01-2ubuntu0.1 Not available 21 Dec, 2017
  • L
Denial of Service (DoS)
debian:10: <2.13.02-0.1,debian:8: *,debian:9: *,debian:unstable: <2.13.02-0.1,ubuntu:14.04: <2.10.09-1ubuntu0.1,ubuntu:16.04: <2.11.08-1ubuntu0.1,ubuntu:17.10: <2.13.01-2ubuntu0.1 Not available 21 Dec, 2017
  • L
Denial of Service (DoS)
debian:10: <2.13.02-0.1,debian:8: *,debian:9: *,debian:unstable: <2.13.02-0.1,ubuntu:14.04: <2.10.09-1ubuntu0.1,ubuntu:16.04: <2.11.08-1ubuntu0.1,ubuntu:17.10: <2.13.01-2ubuntu0.1 Not available 21 Dec, 2017
  • M
Denial of Service (DoS)
debian:10: <2.13.02-0.1,debian:8: *,debian:9: *,debian:unstable: <2.13.02-0.1,ubuntu:14.04: <2.10.09-1ubuntu0.1,ubuntu:16.04: <2.11.08-1ubuntu0.1,ubuntu:17.10: <2.13.01-2ubuntu0.1 Not available 21 Dec, 2017
  • M
Denial of Service (DoS)
debian:10: <2.13.02-0.1,debian:8: *,debian:9: *,debian:unstable: <2.13.02-0.1,ubuntu:14.04: <2.10.09-1ubuntu0.1,ubuntu:16.04: <2.11.08-1ubuntu0.1,ubuntu:17.10: <2.13.01-2ubuntu0.1 Not available 21 Dec, 2017
  • L
Improper Check for Unusual or Exceptional Conditions
debian:10: <2.13.02-0.1,debian:8: *,debian:9: *,debian:unstable: <2.13.02-0.1,ubuntu:14.04: <2.10.09-1ubuntu0.1,ubuntu:16.04: <2.11.08-1ubuntu0.1,ubuntu:17.10: <2.13.01-2ubuntu0.1 Not available 21 Dec, 2017