libsndfile vulnerabilities

Continuously find & fix vulnerabilities like these in your dependencies. Test and protect your applications

Direct Vulnerabilities

Known vulnerabilities in the libsndfile package. This does not include vulnerabilities belonging to this package’s dependencies.

Vulnerability Vulnerable versions Snyk patch Published
  • L
CVE-2019-3832
debian:10: <1.0.28-6,debian:8: <1.0.25-9.1+deb8u4,debian:unstable: <1.0.28-6 Not available 15 Feb, 2019
  • L
CVE-2018-19432
debian:10: *,debian:8: <1.0.25-9.1+deb8u2,debian:9: *,debian:unstable: *,ubuntu:14.04: *,ubuntu:16.04: *,ubuntu:18.04: *,ubuntu:18.10: * Not available 02 Dec, 2018
  • L
CVE-2018-19758
alpine:3.9: <1.0.28-r7,debian:10: <1.0.28-5,debian:8: <1.0.25-9.1+deb8u3,debian:9: *,debian:unstable: <1.0.28-5,ubuntu:14.04: *,ubuntu:16.04: *,ubuntu:18.04: *,ubuntu:18.10: * Not available 30 Nov, 2018
  • L
CVE-2018-19661
alpine:3.9: <1.0.28-r6,debian:10: <1.0.28-5,debian:8: <1.0.25-9.1+deb8u2,debian:9: *,debian:unstable: <1.0.28-5,ubuntu:14.04: *,ubuntu:16.04: *,ubuntu:18.04: *,ubuntu:18.10: * Not available 29 Nov, 2018
  • L
CVE-2018-19662
alpine:3.9: <1.0.28-r6,debian:10: <1.0.28-5,debian:8: <1.0.25-9.1+deb8u2,debian:9: *,debian:unstable: <1.0.28-5,ubuntu:14.04: *,ubuntu:16.04: *,ubuntu:18.04: *,ubuntu:18.10: * Not available 29 Nov, 2018
  • L
CVE-2018-13419
debian:10: *,debian:8: *,debian:9: *,debian:unstable: *,ubuntu:14.04: *,ubuntu:16.04: *,ubuntu:18.04: *,ubuntu:18.10: * Not available 11 Jul, 2018
  • L
Denial of Service (DoS)
alpine:3.5: <1.0.28-r3,alpine:3.6: <1.0.28-r3,alpine:3.7: <1.0.28-r3,alpine:3.8: <1.0.28-r4,alpine:3.9: <1.0.28-r4,debian:10: *,debian:8: <1.0.25-9.1+deb8u2,debian:9: *,debian:unstable: *,ubuntu:14.04: *,ubuntu:16.04: *,ubuntu:18.04: *,ubuntu:18.10: * Not available 11 Jul, 2018
  • M
ELSA-2011-1084
oracle:6: <0:1.0.20-3.el6_1.1 Not available 27 Jun, 2018
  • M
RHSA-2011:1084
centos:6: <0:1.0.20-3.el6_1.1 Not available 27 Jun, 2018
  • L
Out-of-bounds Read
alpine:3.9: <1.0.28-r6,debian:10: <1.0.28-5,debian:8: <1.0.25-9.1+deb8u2,debian:9: *,debian:unstable: <1.0.28-5,ubuntu:14.04: *,ubuntu:16.04: *,ubuntu:18.04: *,ubuntu:18.10: * Not available 07 Dec, 2017
  • L
Out-of-bounds Read
alpine:3.9: <1.0.28-r6,debian:10: <1.0.28-5,debian:8: <1.0.25-9.1+deb8u2,debian:9: *,debian:unstable: <1.0.28-5,ubuntu:14.04: *,ubuntu:16.04: *,ubuntu:18.04: *,ubuntu:18.10: * Not available 07 Dec, 2017
  • L
Denial of Service (DoS)
debian:10: <1.0.27-1,debian:8: *,debian:9: <1.0.27-1,debian:unstable: <1.0.27-1,ubuntu:14.04: *,ubuntu:16.04: * Not available 25 Nov, 2017
  • L
Out-of-bounds Read
debian:10: <1.0.28-5,debian:8: <1.0.25-9.1+deb8u2,debian:9: *,debian:unstable: <1.0.28-5,ubuntu:14.04: *,ubuntu:16.04: *,ubuntu:18.04: *,ubuntu:18.10: * Not available 21 Sep, 2017
  • L
Out-of-bounds Read
debian:10: <1.0.28-5,debian:8: <1.0.25-9.1+deb8u2,debian:9: *,debian:unstable: <1.0.28-5,ubuntu:14.04: *,ubuntu:16.04: *,ubuntu:18.04: *,ubuntu:18.10: * Not available 21 Sep, 2017
  • M
Denial of Service (DoS)
debian:10: <1.0.28-5,debian:8: <1.0.25-9.1+deb8u2,debian:9: *,debian:unstable: <1.0.28-5,ubuntu:14.04: *,ubuntu:16.04: *,ubuntu:18.04: *,ubuntu:18.10: * Not available 21 Sep, 2017
  • H
Denial of Service (DoS)
alpine:3.3: <1.0.28-r2,alpine:3.4: <1.0.28-r2,alpine:3.5: <1.0.28-r2,alpine:3.6: <1.0.28-r2,alpine:3.7: <1.0.28-r2,alpine:3.8: <1.0.28-r2,alpine:3.9: <1.0.28-r2,debian:10: <1.0.28-3,debian:8: *,debian:9: *,debian:unstable: <1.0.28-3,ubuntu:14.04: *,ubuntu:16.04: * Not available 05 Aug, 2017
  • L
Improper Restriction of Operations within the Bounds of a Memory Buffer
debian:10: <1.0.28-1,debian:8: *,debian:9: *,debian:unstable: <1.0.28-1,ubuntu:14.04: *,ubuntu:16.04: * Not available 12 Jun, 2017
  • L
Denial of Service (DoS)
alpine:3.3: <1.0.28-r1,alpine:3.4: <1.0.28-r1,alpine:3.5: <1.0.28-r1,alpine:3.6: <1.0.28-r1,alpine:3.7: <1.0.28-r1,alpine:3.8: <1.0.28-r1,alpine:3.9: <1.0.28-r1,debian:10: <1.0.27-3,debian:8: <1.0.25-9.1+deb8u2,debian:9: <1.0.27-3,debian:unstable: <1.0.27-3,ubuntu:14.04: <1.0.25-7ubuntu2.2,ubuntu:16.04: <1.0.25-10ubuntu0.16.04.1,ubuntu:16.10: <1.0.25-10ubuntu0.16.10.1,ubuntu:17.04: <1.0.27-1ubuntu0.1 Not available 30 Apr, 2017
  • M
Denial of Service (DoS)
alpine:3.3: <1.0.28-r1,alpine:3.4: <1.0.28-r1,alpine:3.5: <1.0.28-r1,alpine:3.6: <1.0.28-r1,alpine:3.7: <1.0.28-r1,alpine:3.8: <1.0.28-r1,alpine:3.9: <1.0.28-r1,debian:10: <1.0.27-3,debian:8: <1.0.25-9.1+deb8u2,debian:9: <1.0.27-3,debian:unstable: <1.0.27-3,ubuntu:14.04: <1.0.25-7ubuntu2.2,ubuntu:16.04: <1.0.25-10ubuntu0.16.04.1,ubuntu:16.10: <1.0.25-10ubuntu0.16.10.1,ubuntu:17.04: <1.0.27-1ubuntu0.1 Not available 30 Apr, 2017
  • M
Denial of Service (DoS)
alpine:3.3: <1.0.28-r1,alpine:3.4: <1.0.28-r1,alpine:3.5: <1.0.28-r1,alpine:3.6: <1.0.28-r1,alpine:3.7: <1.0.28-r1,alpine:3.8: <1.0.28-r1,alpine:3.9: <1.0.28-r1,debian:10: <1.0.27-3,debian:8: <1.0.25-9.1+deb8u2,debian:9: <1.0.27-3,debian:unstable: <1.0.27-3,ubuntu:14.04: <1.0.25-7ubuntu2.2,ubuntu:16.04: <1.0.25-10ubuntu0.16.04.1,ubuntu:16.10: <1.0.25-10ubuntu0.16.10.1,ubuntu:17.04: <1.0.27-1ubuntu0.1 Not available 30 Apr, 2017
  • M
Denial of Service (DoS)
alpine:3.3: <1.0.28-r1,alpine:3.4: <1.0.28-r1,alpine:3.5: <1.0.28-r1,alpine:3.6: <1.0.28-r1,alpine:3.7: <1.0.28-r1,alpine:3.8: <1.0.28-r1,alpine:3.9: <1.0.28-r1,debian:10: <1.0.27-3,debian:8: <1.0.25-9.1+deb8u2,debian:9: <1.0.27-3,debian:unstable: <1.0.27-3,ubuntu:14.04: <1.0.25-7ubuntu2.2,ubuntu:16.04: <1.0.25-10ubuntu0.16.04.1,ubuntu:16.10: <1.0.25-10ubuntu0.16.10.1,ubuntu:17.04: <1.0.27-1ubuntu0.1 Not available 30 Apr, 2017
  • M
Improper Restriction of Operations within the Bounds of a Memory Buffer
alpine:3.3: <1.0.28-r0,alpine:3.4: <1.0.28-r0,alpine:3.5: <1.0.28-r0,alpine:3.6: <1.0.28-r0,alpine:3.7: <1.0.28-r0,alpine:3.8: <1.0.28-r0,alpine:3.9: <1.0.28-r0,debian:10: <1.0.27-3,debian:8: *,debian:9: <1.0.27-3,debian:unstable: <1.0.27-3,ubuntu:14.04: <1.0.25-7ubuntu2.2,ubuntu:16.04: <1.0.25-10ubuntu0.16.04.1,ubuntu:16.10: <1.0.25-10ubuntu0.16.10.1,ubuntu:17.04: <1.0.27-1ubuntu0.1 Not available 12 Apr, 2017
  • M
Improper Restriction of Operations within the Bounds of a Memory Buffer
alpine:3.3: <1.0.28-r0,alpine:3.4: <1.0.28-r0,alpine:3.5: <1.0.28-r0,alpine:3.6: <1.0.28-r0,alpine:3.7: <1.0.28-r0,alpine:3.8: <1.0.28-r0,alpine:3.9: <1.0.28-r0,debian:10: <1.0.27-2,debian:8: *,debian:9: <1.0.27-2,debian:unstable: <1.0.27-2,ubuntu:14.04: <1.0.25-7ubuntu2.2,ubuntu:16.04: <1.0.25-10ubuntu0.16.04.1,ubuntu:16.10: <1.0.25-10ubuntu0.16.10.1,ubuntu:17.04: <1.0.27-1ubuntu0.1 Not available 12 Apr, 2017
  • M
Improper Restriction of Operations within the Bounds of a Memory Buffer
debian:10: <1.0.27-2,debian:8: *,debian:9: <1.0.27-2,debian:unstable: <1.0.27-2,ubuntu:14.04: <1.0.25-7ubuntu2.2,ubuntu:16.04: <1.0.25-10ubuntu0.16.04.1,ubuntu:16.10: <1.0.25-10ubuntu0.16.10.1,ubuntu:17.04: <1.0.27-1ubuntu0.1 Not available 07 Apr, 2017
  • L
Improper Restriction of Operations within the Bounds of a Memory Buffer
alpine:3.3: <1.0.28-r0,alpine:3.4: <1.0.28-r0,alpine:3.5: <1.0.28-r0,alpine:3.6: <1.0.28-r0,alpine:3.7: <1.0.28-r0,alpine:3.8: <1.0.28-r0,alpine:3.9: <1.0.28-r0,debian:10: <1.0.27-2,debian:8: *,debian:9: <1.0.27-2,debian:unstable: <1.0.27-2,ubuntu:14.04: <1.0.25-7ubuntu2.2,ubuntu:16.04: <1.0.25-10ubuntu0.16.04.1,ubuntu:16.10: <1.0.25-10ubuntu0.16.10.1,ubuntu:17.04: <1.0.27-1ubuntu0.1 Not available 07 Apr, 2017
  • M
Denial of Service (DoS)
debian:10: <1.0.25-10,debian:8: <1.0.25-9.1+deb8u1,debian:9: <1.0.25-10,debian:unstable: <1.0.25-10,ubuntu:12.04: <1.0.25-4ubuntu0.1,ubuntu:14.04: <1.0.25-7ubuntu2.1,ubuntu:15.04: <1.0.25-9.1ubuntu0.15.04.1,ubuntu:15.10: <1.0.25-9.1ubuntu0.15.10.1 Not available 19 Nov, 2015
  • H
Improper Restriction of Operations within the Bounds of a Memory Buffer
debian:10: <1.0.25-10,debian:8: <1.0.25-9.1+deb8u1,debian:9: <1.0.25-10,debian:unstable: <1.0.25-10,ubuntu:12.04: <1.0.25-4ubuntu0.1,ubuntu:14.04: <1.0.25-7ubuntu2.1,ubuntu:15.04: <1.0.25-9.1ubuntu0.15.04.1,ubuntu:15.10: <1.0.25-9.1ubuntu0.15.10.1 Not available 17 Nov, 2015
  • L
Improper Restriction of Operations within the Bounds of a Memory Buffer
debian:10: <1.0.25-9.1,debian:8: <1.0.25-9.1,debian:9: <1.0.25-9.1,debian:unstable: <1.0.25-9.1,ubuntu:12.04: <1.0.25-4ubuntu0.1,ubuntu:14.04: <1.0.25-7ubuntu2.1 Not available 16 Jan, 2015
  • M
Integer Overflow
debian:10: <1.0.25-1,debian:8: <1.0.25-1,debian:9: <1.0.25-1,debian:unstable: <1.0.25-1 Not available 27 Jul, 2011
  • L
Denial of Service (DoS)
debian:10: <1.0.21-3,debian:8: <1.0.21-3,debian:9: <1.0.21-3,debian:unstable: <1.0.21-3 Not available 06 May, 2010