jackson-databind vulnerabilities

Continuously find & fix vulnerabilities like these in your dependencies. Test and protect your applications

Direct Vulnerabilities

Known vulnerabilities in the jackson-databind package. This does not include vulnerabilities belonging to this package’s dependencies.

Vulnerability Vulnerable versions Snyk patch Published
  • L
CVE-2019-12086
debian:10: *,debian:8: <2.4.2-2+deb8u6,debian:9: *,debian:unstable: <2.9.8-2 Not available 17 May, 2019
  • L
CVE-2018-11307
debian:10: <2.9.8-1,debian:8: <2.4.2-2+deb8u5,debian:9: *,debian:unstable: <2.9.8-1 Not available 15 Feb, 2019
  • L
CVE-2018-12023
debian:10: <2.9.8-1,debian:8: <2.4.2-2+deb8u5,debian:9: *,debian:unstable: <2.9.8-1 Not available 31 Jan, 2019
  • L
CVE-2018-12022
debian:10: <2.9.8-1,debian:8: <2.4.2-2+deb8u5,debian:9: *,debian:unstable: <2.9.8-1 Not available 31 Jan, 2019
  • M
CVE-2018-14719
debian:10: <2.9.8-1,debian:8: <2.4.2-2+deb8u5,debian:9: *,debian:unstable: <2.9.8-1,ubuntu:14.04: *,ubuntu:16.04: *,ubuntu:18.04: *,ubuntu:18.10: * Not available 02 Jan, 2019
  • M
CVE-2018-14720
debian:10: <2.9.8-1,debian:8: <2.4.2-2+deb8u5,debian:9: *,debian:unstable: <2.9.8-1,ubuntu:14.04: *,ubuntu:16.04: *,ubuntu:18.04: *,ubuntu:18.10: * Not available 02 Jan, 2019
  • M
CVE-2018-19361
debian:10: <2.9.8-1,debian:8: <2.4.2-2+deb8u5,debian:9: *,debian:unstable: <2.9.8-1,ubuntu:18.04: *,ubuntu:18.10: * Not available 02 Jan, 2019
  • M
CVE-2018-14721
debian:10: <2.9.8-1,debian:8: <2.4.2-2+deb8u5,debian:9: *,debian:unstable: <2.9.8-1,ubuntu:14.04: *,ubuntu:16.04: *,ubuntu:18.04: *,ubuntu:18.10: * Not available 02 Jan, 2019
  • M
CVE-2018-19360
debian:10: <2.9.8-1,debian:8: <2.4.2-2+deb8u5,debian:9: *,debian:unstable: <2.9.8-1,ubuntu:18.04: *,ubuntu:18.10: * Not available 02 Jan, 2019
  • M
CVE-2018-14718
debian:10: <2.9.8-1,debian:8: <2.4.2-2+deb8u5,debian:9: *,debian:unstable: <2.9.8-1,ubuntu:14.04: *,ubuntu:16.04: *,ubuntu:18.04: *,ubuntu:18.10: * Not available 02 Jan, 2019
  • M
CVE-2018-19362
debian:10: <2.9.8-1,debian:8: <2.4.2-2+deb8u5,debian:9: *,debian:unstable: <2.9.8-1,ubuntu:18.04: *,ubuntu:18.10: * Not available 02 Jan, 2019
  • H
Deserialization of Untrusted Data
debian:10: <2.9.5-1,debian:8: <2.4.2-2+deb8u4,debian:9: <2.8.6-1+deb9u4,debian:unstable: <2.9.5-1,ubuntu:17.10: <2.8.6-1+deb9u4build0.17.10.1 Not available 26 Feb, 2018
  • H
Deserialization of Untrusted Data
debian:10: <2.9.1-1,debian:8: <2.4.2-2+deb8u2,debian:9: <2.8.6-1+deb9u2,debian:unstable: <2.9.1-1,ubuntu:14.04: *,ubuntu:16.04: *,ubuntu:17.04: <2.8.6-1+deb9u2build0.17.04.1,ubuntu:17.10: <2.8.6-1+deb9u2build0.17.10.1 Not available 06 Feb, 2018
  • M
Deserialization of Untrusted Data
debian:10: <2.9.1-1,debian:8: <2.4.2-2+deb8u1,debian:9: <2.8.6-1+deb9u1,debian:unstable: <2.9.1-1,ubuntu:14.04: *,ubuntu:16.04: *,ubuntu:17.04: <2.8.6-1+deb9u1build0.17.04.1,ubuntu:17.10: <2.8.6-1+deb9u1build0.17.10.1 Not available 06 Feb, 2018
  • M
Deserialization of Untrusted Data
debian:10: <2.9.4-1,debian:8: <2.4.2-2+deb8u3,debian:9: <2.8.6-1+deb9u3,debian:unstable: <2.9.4-1,ubuntu:17.10: <2.8.6-1+deb9u3build0.17.10.1 Not available 22 Jan, 2018
  • H
Arbitrary Code Injection
debian:10: <2.9.4-1,debian:8: <2.4.2-2+deb8u3,debian:9: <2.8.6-1+deb9u3,debian:unstable: <2.9.4-1,ubuntu:14.04: *,ubuntu:16.04: * Not available 10 Jan, 2018