github.com/hashicorp/vault/vault vulnerabilities

Licenses detected

Continuously find & fix vulnerabilities like these in your dependencies. Test and protect your applications

Direct Vulnerabilities

Known vulnerabilities in the github.com/hashicorp/vault/vault package. This does not include vulnerabilities belonging to this package’s dependencies.

Report new vulnerabilities
Vulnerability Vulnerable versions Snyk patch Published
  • M
Improper Authentication
>=1.7.0 <1.7.2,>=1.6.0 <1.6.5,<1.5.9 Not available 04 Jun, 2021
  • M
Information Exposure
>=1.6.0 <1.6.2,<1.5.7 Not available 02 Feb, 2021
  • M
Privilege Escalation
<0.12.10,>=1.0.0 <1.0.3 Not available 02 Feb, 2021
  • M
Information Exposure
>=1.6.0 <1.6.2,<1.5.7 Not available 02 Feb, 2021
  • M
Improper Authentication
<1.6.2 Not available 02 Feb, 2021
  • M
Authentication Bypass
>=0.8.1 <1.2.5,>=1.3.0 <1.3.8,>=1.4.0 <1.4.4,>=1.5.0 <1.5.1 Not available 27 Aug, 2020
  • M
Authentication Bypass
>=0.8.3 <1.2.5,>=1.3.0 <1.3.8,>=1.4.0 <1.4.4,>=1.5.0 <1.5.1 Not available 27 Aug, 2020
  • M
Privilege Escalation
>=0.11.0 <1.3.3 Not available 23 Mar, 2020
  • M
Privilege Escalation
>=0.9.0 <1.3.4 Not available 23 Mar, 2020