Improper Access Control

Affecting showdoc/showdoc gem, versions <2.4.2

medium severity

Overview

showdoc/showdoc is a tool greatly applicable for an IT team to share documents online.

Affected versions of this package are vulnerable to Improper Access Control. A malicious user could edit other users note by navigating with a modified page_id.

Remedaition

Upgrade showdoc/showdoc to version 2.4.2 or higher.

References

Do your applications use this vulnerable package?

Credit
Unknown
CVE
CVE-2018-19620
CWE
CWE-284
Snyk ID
SNYK-RUBY-SHOWDOCSHOWDOC-72642
Disclosed
28 Nov, 2018
Published
28 Nov, 2018