Arbitrary Code Injection

Affecting restforce gem, versions <3.0.0

Overview

https://rubygems.org/gems/restforce is A lightweight ruby client for the Salesforce REST API.

Affected versions of this package are vulnerable to Arbitrary Code Injection. An attacker could inject additional parameters into Salesforce API requests due to the way restforce constructs URL's.

Note This flaw is only exploitable in applications that pass user input directly to restforce's select, find, describe, update, upsert, and destroy methods.

Remediation

Upgrade restforce to version 3.0.0 or higher.

References

Do your applications use this vulnerable package?

CVSS Score

9.8
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Credit
Unknown
CVE
CVE-2018-3777
CWE
CWE-94
Snyk ID
SNYK-RUBY-RESTFORCE-22045
Disclosed
03 Aug, 2018
Published
05 Aug, 2018