Arbitrary Code Loading
Affecting puppet gem, versions <5.3.7 || >=5.4.0, <5.5.2
puppet is an an automated configuration management tool.
Affected versions of this package are vulnerable to Arbitrary Code Loading. With a specially crafted configuration file an attacker could get
pxp-agent to load arbitrary code with privilege escalation.
puppet to versions 5.3.7, 5.5.2 or higher.