Arbitrary Code Loading

Affecting puppet gem, versions <5.3.7 || >=5.4.0, <5.5.2

high severity

Overview

puppet is an an automated configuration management tool.

Affected versions of this package are vulnerable to Arbitrary Code Loading. With a specially crafted configuration file an attacker could get pxp-agent to load arbitrary code with privilege escalation.

Remediation

Upgrade puppet to versions 5.3.7, 5.5.2 or higher.

References

Do your applications use this vulnerable package?

Credit
Unknown
CVE
CVE-2018-6515
CWE
CWE-94
Snyk ID
SNYK-RUBY-PUPPET-22031
Disclosed
08 Jun, 2018
Published
17 Jun, 2018