Improper Access Control

Affecting passenger gem, versions <5.3.2

Do your applications use this vulnerable package? Test your applications

Overview

passenger is a modern web server and application server for Ruby, Python and Node.js, optimized for performance, low memory usage and ease of use.

Affected versions of this package are vulnerable to Improper Access Control. Passenger-managed malicious application, upon spawning a child process, could report an arbitrary different PID back to Passenger's process manager. If the malicious application then generates an error, it would cause Passenger's process manager to kill said reported arbitrary PID.

Remediation

Upgrade passenger to version 5.3.2 or higher.

References

CVSS Score

7.8
high severity
  • Attack Vector
    Local
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Credit
Unknown
CVE
CVE-2018-12028
CWE
CWE-284
Snyk ID
SNYK-RUBY-PASSENGER-22035
Disclosed
12 Jun, 2018
Published
20 Jun, 2018