Insecure Permissions

Affecting passenger gem, versions <5.3.2

Do your applications use this vulnerable package? Test your applications

Overview

passenger is a modern web server and application server for Ruby, Python and Node.js, optimized for performance, low memory usage and ease of use.

Affected versions of this package are vulnerable to Insecure Permissions. Given a Passenger-spawned application process that reports that it listens on a certain Unix domain socket, if any of the parent directories of said socket are writable by a normal user that is not the application's user, then that non-application user can swap that directory with something else, resulting in traffic being redirected to a non-application user's process through an alternative Unix domain socket.

Remediation

Upgrade passenger to version 5.3.2 or higher.

References

CVSS Score

8.8
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    Low
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Credit
Unknown
CVE
CVE-2018-12027
CWE
CWE-275
Snyk ID
SNYK-RUBY-PASSENGER-22034
Disclosed
12 Jun, 2018
Published
20 Jun, 2018