Denial of Service (DoS)

Affecting asciidoctor gem, versions <1.5.8

medium severity

Overview

Asciidoctor is open source text processor and publishing toolchain, written in Ruby, for converting AsciiDoc content to HTML5, DocBook 5 (or 4.5) and other formats.

Affected versions of this package are vulnerable to Denial of Service (DoS) attacks via the next_block method.

Remediation

Upgrade Asciidoctor to version 1.5.8 or higher.

References

Do your applications use this vulnerable package?

Credit
Unknown
CVE
CVE-2018-18385
CWE
CWE-400
Snyk ID
SNYK-RUBY-ASCIIDOCTOR-72630
Disclosed
16 Sep, 2018
Published
28 Oct, 2018