Cross-site Request Forgery (CSRF)

Affecting luigi package, versions [2.3.3,2.8.0)

Do your applications use this vulnerable package? Test your applications

Overview

luigi is a package that helps you build complex pipelines of batch jobs. It handles dependency resolution, workflow management, visualization, handling failures, command line integration, and much more.

Affected versions of this package are vulnerable to Cross-site Request Forgery (CSRF) via API endpoint: /api/ that can expose task metadata such as task name, id, parameter, etc to an unauthorized users. This attack can be exploited only when the victim visits a specially crafted webpage from the network where their Luigi server is accessible.

Remediation

Upgrade luigi to version 2.8.0 or higher.

References

CVSS Score

6.5
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    None
  • Availability
    None
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N
Credit
Unknown
CVE
CVE-2018-1000843
CWE
CWE-352
Snyk ID
SNYK-PYTHON-LUIGI-72726
Disclosed
20 Dec, 2018
Published
24 Dec, 2018