Information Exposure

Affecting ansible package, versions [,2.5.12) || [26.0, 2.6.9) || [2.7.2, 2.7.3)

medium severity

Overview

ansible is a simple IT automation system.

Affected versions of this package are vulnerable to Information Exposure. Execution of ansible playbooks on Windows platforms with PowerShell ScriptBlock logging and Module logging enabled can allow for passwords to appear in EventLogs in plaintext. A malicious user with administrator privileges on the machine can view these logs and discover the plaintext password.

Remediation

Upgrade ansible to version 2.5.12, 2.6.9, 2.7.3 or higher.

References

Do your applications use this vulnerable package?

Credit
Unknown
CVE
CVE-2018-16859
CWE
CWE-200
Snyk ID
SNYK-PYTHON-ANSIBLE-72650
Disclosed
29 Nov, 2018
Published
03 Dec, 2018