Information Exposure

Affecting ansible package, versions [,2.7.1)

high severity

Overview

ansible is a radically simple IT automation system.

Affected versions of this package are vulnerable to Information Exposure. The User module would leak any data which is passed on as a parameter to ssh-keygen.

Remediation

Upgrade ansible to version 2.7.1 or higher.

References

Do your applications use this vulnerable package?

Credit
Markus Teufelberger
CVE
CVE-2018-16837
CWE
CWE-214
Snyk ID
SNYK-PYTHON-ANSIBLE-72546
Disclosed
24 Oct, 2018
Published
29 Oct, 2018