Arbitrary Command Execution

Affecting yoast/wordpress-seo package, versions <9.2.0

Do your applications use this vulnerable package? Test your applications

Overview

yoast/wordpress-seo is a Yoast SEO for WordPress.

Affected versions of this package are vulnerable to Arbitrary Command Execution due to a race condition via the admin/import/class-import-settings.php path in unzip_file. A SEO Manager could perform command execution on the Operating System via a ZIP import.

Remediation

Upgrade yoast/wordpress-seo to version 9.2.0 or higher.

References

CVSS Score

7.2
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    High
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Credit
gweeperx
CVE
CVE-2018-19370
CWE
CWE-94
Snyk ID
SNYK-PHP-YOASTWORDPRESSSEO-72648
Disclosed
28 Nov, 2018
Published
29 Nov, 2018