Information Exposure

Affecting yiisoft/yii2 package, versions >=2.0, <2.0.14

Do your applications use this vulnerable package? Test your applications

Overview

yiisoft/yii2 is a framework designed to be a solid foundation for PHP.

Affected versions of this package are vulnerable to Information Exposure. An attacker could obtain potentially sensitive information from exception messages printed by the error handler in non-debug mode.

Remediation

Upgrade yiisoft/yii2 to version 2.0.14 or higher.

References

CVSS Score

7.5
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    None
  • Availability
    None
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Credit
Alexander Makarov
CVE
CVE-2018-6010
CWE
CWE-200
Snyk ID
SNYK-PHP-YIISOFTYII2-72036
Disclosed
17 Jan, 2018
Published
18 Feb, 2018