Arbitrary Code Injection

Affecting woocommerce/woocommerce package, versions <3.2.4

Overview

woocommerce/woocommerce is an eCommerce toolkit that helps you sell anything.

Affected versions of this package are vulnerable to Arbitrary Code Injection. An attacker with user account could construct a specifically crafted string that will turn into a PHP object injection involving the includes/shortcodes/class-wc-shortcode-products.php WC_Shortcode_Products::get_products() use of cached queries within shortcodes.

Remediation

Upgrade woocommerce/woocommerce to version 3.2.4 or higher.

References

Do your applications use this vulnerable package?

CVSS Score

6.3
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    Low
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    Low
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
Credit
Unknown
CVE
CVE-2017-18356
CWE
CWE-94
Snyk ID
SNYK-PHP-WOOCOMMERCEWOOCOMMERCE-73653
Disclosed
10 Feb, 2019
Published
16 Jan, 2019