Arbitrary Code Execution

Affecting symfony/symfony package, versions >=4.2.0, <4.2.12 || >=4.3.0, <4.3.8

Do your applications use this vulnerable package? Test your applications

Overview

symfony/symfony is a PHP framework for web applications and a set of reusable PHP components.

Affected versions of this package are vulnerable to Arbitrary Code Execution. Some strings were not properly escaped when being dumped by the VarExporter component leading to remote code execution.

Remediation

Upgrade symfony/symfony to version 4.2.12, 4.3.8 or higher.

References

CVSS Score

7.3
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    Low
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Credit
Seung Woo Yuk (xtac)
CVE
CVE-2019-11325
CWE
CWE-94
Snyk ID
SNYK-PHP-SYMFONYSYMFONY-535352
Disclosed
13 Nov, 2019
Published
22 Nov, 2019