Arbitrary Code Execution

Affecting symfony/http-foundation package, versions >=2.8.0, <2.8.52 || >=3.4.0, <3.4.35 || >=4.2.0, <4.2.11 || >=4.3.0, <4.3.8

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

symfony/http-foundation is a component defines an object-oriented layer for the HTTP specification.

Affected versions of this package are vulnerable to Arbitrary Code Execution. Provided file paths were not being properly escaped before being used in the FileBinaryMimeTypeGuesser resulting in potential argument injection through the provided $path variable.

Remediation

Upgrade symfony/http-foundation to version 2.8.52, 3.4.35, 4.2.11, 4.3.8 or higher.

References

CVSS Score

7.3
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    Low
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Credit
Ivan Novikov
CVE
CVE-2019-18888
CWE
CWE-94
Snyk ID
SNYK-PHP-SYMFONYHTTPFOUNDATION-535378
Disclosed
13 Nov, 2019
Published
22 Nov, 2019