Arbitrary Code Execution

Affecting symfony/cache package, versions >=3.4.0, <3.4.35 || >=4.2.0, <4.2.12 || >=4.3.0, <4.3.8

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

symfony/cache is a cache component provides an extended PSR-6 implementation for adding cache to your applications.

Affected versions of this package are vulnerable to Arbitrary Code Execution. When an instance of TagAwareAdapter is destructed, Symfony execute callables stored in privates properties in order to invalidates tags. When the instance has been created by unserializing an external payload, those properties are not checked leading to a remote code execution.

Remediation

Upgrade symfony/cache to version 3.4.35, 4.2.12, 4.3.8 or higher.

References

CVSS Score

7.3
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    Low
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Credit
wisdomtree
CVE
CVE-2019-18889
CWE
CWE-94
Snyk ID
SNYK-PHP-SYMFONYCACHE-535380
Disclosed
13 Nov, 2019
Published
22 Nov, 2019