SQL Injection

Affecting pimcore/pimcore package, versions <6.3.0

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

pimcore/pimcore is a content & product management framework (CMS/PIM/E-Commerce).

Affected versions of this package are vulnerable to SQL Injection. An attacker with limited privileges (classes permission) can achieve a SQL injection that can lead in data leakage. The vulnerability can be exploited via id, storeId, pageSize and tables parameters, using a payload for trigger a time based or error based sql injection.

Remediation

Upgrade pimcore/pimcore to version 6.3.0 or higher.

References

CVSS Score

6.7
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    High
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    Low
  • Availability
    High
CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:L/A:H
Credit
Daniele Scanu
CVE
CVE-2019-10763
CWE
CWE-89
Snyk ID
SNYK-PHP-PIMCOREPIMCORE-480391
Disclosed
17 Nov, 2019
Published
17 Nov, 2019