Arbitrary File Read

Affecting phpmyadmin/phpmyadmin package, versions >=4.0.0, <4.8.5

Overview

phpmyadmin/phpmyadmin is a web interface for MySQL and MariaDB.

Affected versions of this package are vulnerable to Arbitrary File Read. An attacker could read any file on the server that the web server's user could access.

Note This vulnerability is exploitable only when the AllowArbitraryServer configuration set to true.

Remediation

Upgrade phpmyadmin/phpmyadmin to version 4.8.5 or higher.

References

Do your applications use this vulnerable package?

CVSS Score

9.8
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Credit
Unknown
CVE
CVE-2019-6799
CWE
CWE-23
Snyk ID
SNYK-PHP-PHPMYADMINPHPMYADMIN-73617
Disclosed
26 Jan, 2019
Published
26 Jan, 2019