SQL Injection

Affecting phpmyadmin/phpmyadmin package, versions >=4.5.0, <4.8.5

Overview

phpmyadmin/phpmyadmin is a web interface for MySQL and MariaDB.

Affected versions of this package are vulnerable to SQL Injection via the designer feature.

Remediation

Upgrade phpmyadmin/phpmyadmin to version 4.8.5 or higher.

References

Do your applications use this vulnerable package?

CVSS Score

7.3
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    Low
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Credit
YU-HSIANG HUANG, YUNG-HAO TSENG, Eddie TC CHANG
CVE
CVE-2019-6798
CWE
CWE-89
Snyk ID
SNYK-PHP-PHPMYADMINPHPMYADMIN-73616
Disclosed
26 Jan, 2019
Published
26 Jan, 2019