SQL Injection

Affecting phpmyadmin/phpmyadmin package, versions <4.9.2

Do your applications use this vulnerable package? Test your applications

Overview

phpmyadmin/phpmyadmin is a web interface for MySQL and MariaDB.

Affected versions of this package are vulnerable to SQL Injection. A crafted database/table name can be used to trigger a SQL injection attack through the designer feature.

Remediation

Upgrade phpmyadmin/phpmyadmin to version 4.9.2 or higher.

References

CVSS Score

7.3
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    Low
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Credit
Unknown
CVE
CVE-2019-18622
CWE
CWE-89
Snyk ID
SNYK-PHP-PHPMYADMINPHPMYADMIN-535488
Disclosed
22 Nov, 2019
Published
22 Nov, 2019