Deserialization of Untrusted Data

Affecting ezsystems/ezpublish-legacy package, versions >=5.4.0, <5.4.12.3 || >=5.3.0, <5.3.12.6 || >=2011.0.0, <2017.12.4.3 || >=2018.6.0, <2018.6.1.4 || >=2018.9.0, <2018.9.1.3

high severity

Overview

ezsystems/ezpublish-legacy is a professional PHP application framework with advanced CMS (content management system) functionality.

Affected versions of this package are vulnerable to Deserialization of Untrusted Data. PHAR archives may be crafted such that its stream wrapper will execute them without being specifically asked to. With such files, any PHP file operation may cause deserialisation and execution.

Remediation

Upgrade ezsystems/ezpublish-legacy to versions 5.3.12.6, 5.4.12.3, 2018.9.1.3, 2018.6.1.4 or higher.

References

Do your applications use this vulnerable package?

Credit
Unknown
CWE
CWE-502
Snyk ID
SNYK-PHP-EZSYSTEMSEZPUBLISHLEGACY-72645
Disclosed
26 Nov, 2018
Published
29 Nov, 2018