Cross-site Scripting (XSS)

Affecting ezsystems/ezpublish-legacy package, versions >=5.3.0, <5.3.12.5 || >=5.4.0, <5.4.12.2 || >=2017.12.0, <2017.12.4.2 || >=2018.6.0,  <2018.6.1.3 || >=2018.9.0, <2018.9.1.2

Overview

ezsystems/ezpublish-legacy is a PHP application framework with advanced CMS (content management system) functionality.

Affected versions of this package are vulnerable to Cross-site Scripting (XSS) attacks via the 'disabled module error template.

Details

Cross-Site Scripting (XSS) attacks occur when an attacker tricks a user’s browser to execute malicious JavaScript code in the context of a victim’s domain. Such scripts can steal the user’s session cookies for the domain, scrape or modify its content, and perform or modify actions on the user’s behalf, actions typically blocked by the browser’s Same Origin Policy.

These attacks are possible by escaping the context of the web application and injecting malicious scripts in an otherwise trusted website. These scripts can introduce additional attributes (say, a "new" option in a dropdown list or a new link to a malicious site) and can potentially execute code on the clients side, unbeknown to the victim. This occurs when characters like < > " ' are not escaped properly.

There are a few types of XSS:

  • Persistent XSS is an attack in which the malicious code persists into the web app’s database.
  • Reflected XSS is an which the website echoes back a portion of the request. The attacker needs to trick the user into clicking a malicious link (for instance through a phishing email or malicious JS on another page), which triggers the XSS attack.
  • DOM-based XSS is an that occurs purely in the browser when client-side JavaScript echoes back a portion of the URL onto the page. DOM-Based XSS is notoriously hard to detect, as the server never gets a chance to see the attack taking place.

Remediation

Upgrade ezsystems/ezpublish-legacy to versions 2018.09.1.2, 2018.06.1.3, 2017.12.4.2, 5.4.12.2, 5.3.12.5 or higher.

References

Do your applications use this vulnerable package?

CVSS Score

6.3
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    Low
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    Low
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
Credit
Unknown
CWE
CWE-79
Snyk ID
SNYK-PHP-EZSYSTEMSEZPUBLISHLEGACY-72561
Disclosed
01 Nov, 2018
Published
04 Nov, 2018