Authentication Bypass

Affecting ezsystems/ezpublish-legacy package, versions >=5.4.0, <5.4.12.1 || >=2017.12.0, <2017.12.4.1 || >=5.3.0, <5.3.12.4 || >=2018.6.0, <2018.6.1.2 || >=2018.9.0, <2018.9.1.1

Do your applications use this vulnerable package? Test your applications

Overview

ezsystems/ezpublish-legacy is a PHP application framework with advanced CMS (content management system) functionality.

Affected versions of this package are vulnerable to Authentication Bypass. Installations that are using the legacy LDAP login handler or the TextFile login handler in combination with the standard legacy login handler, may in fail to verify passwords correctly, allowing unauthorised access.

Remediation

Upgrade ezsystems/ezpublish-legacy to versions 5.3.12.4, 5.4.12.1, 2017.12.4.1, 2018.06.1.2, 2018.09.1.1 or higher.

References

CVSS Score

5.6
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    High
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    Low
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L
Credit
Unknown
CWE
CWE-288
Snyk ID
SNYK-PHP-EZSYSTEMSEZPUBLISHLEGACY-72554
Disclosed
05 Oct, 2018
Published
04 Nov, 2018