Information Exposure

Affecting ezsystems/ezpublish-kernel package, versions >=5.3.0, <5.3.12.1 || >=5.4.0, <5.4.13.1 || >=6.0.0, <6.7.9.1 || >=6.8.0, <6.13.5.1 || >=7.0.0, <7.2.4.1 || >=7.3.0, <7.3.2.1

Do your applications use this vulnerable package? Test your applications

Overview

ezsystems/ezpublish-kernel Provides the Content Repository, its APIs, and the application's Symfony framework integration.

Affected versions of this package are vulnerable to Information Exposure. The REST API may be made to disclose the names of all available site accesses.

Remediation

Upgrade ezsystems/ezpublish-kernel to versions 7.3.2.1, 7.2.4.1, 6.13.5.1 , 6.7.9.1 or higher.

References

CVSS Score

5.3
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    None
  • Availability
    None
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Credit
Unknown
CWE
CWE-200
Snyk ID
SNYK-PHP-EZSYSTEMSEZPUBLISHKERNEL-72636
Disclosed
26 Nov, 2018
Published
28 Nov, 2018