Privilege Escalation

Affecting ezsystems/ezplatform package, versions <1.7.8.1 || >=1.8.0, <1.13.4.1 || >=2.0.0, <2.2.3.1 || >=2.3.0, <2.3.2.1

Do your applications use this vulnerable package? Test your applications

Overview

ezsystems/ezplatform is a Meta repository that pulls in all dependencies for clean distribution of eZ Platform.

Affected versions of this package are vulnerable to Privilege Escalation. The sample web server configuration in the documentation can in some cases allow the execution of uploaded PHP/PHAR code, which could lead to privilege escalation.

Remediation

Upgrade ezsystems/ezplatform to versions 1.7.8.1, 1.13.4.1, 2.2.3.1, 2.3.2.1 or higher.

References

CVSS Score

6.5
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    None
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
Credit
Unknown
CWE
CWE-269
Snyk ID
SNYK-PHP-EZSYSTEMSEZPLATFORM-72643
Disclosed
26 Nov, 2018
Published
28 Nov, 2018